kgdc.net
当前位置:首页 >> opEnCv2.4.9和vs2010 >>

opEnCv2.4.9和vs2010

这个是你的环境没配置好,dll找不到,你看一下你的项目->属性->链接器->输入中的附加依赖项的dubeg下是不是写的****249d.lib,release下是不是****249.lib. 这个lib是跟你安装opencv目录下的文件名是一致的,具体是那个文件夹下我也不记得了( ╯□╰ )

不要总看着原来的程序套 cv.h这个头文件,安装指南里说要包含进去的库cv200d.lib也没有了。 #include "cv.h" 语句要改成 #include "opencv2/imgproc/imgproc_c.h" #include "opencv2/imgproc/imgproc.hpp" NO.2 原来的include/opencv文件夹已经...

为了回答你这问题我还刻意下载了Opencv2.4.9版本并解压,发现它与VS2010(VC10)是配套的。

图片路径写对了吗?请把测试图像放到D:\works\testimage.jpg下,然后在程序里使用这个绝对路径调用之。 把程序贴出来看看。

应该是cvnamedwindw或者namedwindow,前一个面向对象,封装较好

这是debug库啊,你引用的lib库有问题吧。 你把这个DLL和你的程序一起发布,就行了

vc11->VS2012 vc12->VS2013 vc13->VS2014 vc14->VS2015 由现在的版本来看,OpenCV 3.2.0只支持VS2015。其实从OpenCV 3.0.0正式版开始就与VS2010不兼容了。如果需要使用最新的版本,还是建议更新VisualStudio的版本。对于VS2010平台,OpenCV 3.0....

http://jingyan.baidu.com/article/ff411625b1311a12e4823784.html

1、下载软件 下载OpenCV-2.4.0,双击解压到%opencv%(凡是出现%opencv%的地方均替换为你自己opencv的路径全名,如D:\program\opencv)。 下载VS2010,安装。 2、配置OpenCV环境变量 计算机->(右键)属性->高级系统设置->高级(标签)->环境变量...

官网下载的不可以,只有vc11和vc2,分别对应VS2012和VS2013。如果非要再VS2010上配置的话,自己编译VS2010版本的。

网站首页 | 网站地图
All rights reserved Powered by www.kgdc.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com